Friday, July 30, 2010

VPLS implementation

To illustrate the flexibility of how you can connect CE devices, the configuration example uses different switch port modes and service-delimiting VLAN tags on each PE router as follows:

1] CE1 sends and receives untagged Ethernet packets that is, null service-delimiting VLAN tags. PE1 configures the switch port mode as dot1q-tunnel to forward packets that have an unmodified Ethernet header. The internal VLAN that is associated with the switch port is 2.

2] CE2 sends and receives tagged Ethernet VLAN packets of which the service-delimiting VLAN
tag is 4. PE2 configures the switch port mode as a trunk to remove or add the service-delimiting VLAN tag accordingly. The internal VLAN that is associated with the switch port is 4.

3] CE3 sends and receives untagged Ethernet packetsthat is, null service-delimiting VLAN tags. PE2 configures the switchport mode as access to forward all untagged packets. The internal VLAN that is associated with the switchport is 8.

4] CE4 sends and receives tagged Ethernet VLAN packets of which the service-delimiting VLAN tag is 10. PE4 configures the switchport mode as a trunk to remove or add the service-delimiting VLAN tag accordingly. The internal VLAN that is associated with the switchport is 10.




Example 15-5. PE1 Configuration

hostname PE1
!
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp router-id Loopback0
!
l2 vfi l2vpn manual
vpn id 1
neighbor 10.0.0.2 encapsulation mpls
neighbor 10.0.0.3 encapsulation mpls
neighbor 10.0.0.4 encapsulation mpls
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
interface POS3/1
ip address 10.0.1.1 255.255.255.252
mpls ip
!
interface FastEthernet4/2
no ip address
switchport
switchport access vlan 2
switchport mode dot1q-tunnel
!
interface Vlan2
no ip address
xconnect vfi l2vpn

Example 15-6. PE2 Configuration

hostname PE2
!
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp router-id Loopback0
!
l2 vfi l2vpn manual
vpn id 1
neighbor 10.0.0.1 encapsulation mpls
neighbor 10.0.0.3 encapsulation mpls
neighbor 10.0.0.4 encapsulation mpls
!
interface Loopback0
ip address 10.0.0.2 255.255.255.255
!
interface POS3/1
ip address 10.0.2.1 255.255.255.252
mpls ip
!
interface FastEthernet4/2
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 4
switchport mode trunk
!
interface Vlan4
no ip address
xconnect vfi l2vpn


Example 15-7. PE3 Configuration

hostname PE3
!
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp router-id Loopback0
!
l2 vfi l2vpn manual
vpn id 1
neighbor 10.0.0.1 encapsulation mpls
neighbor 10.0.0.2 encapsulation mpls
neighbor 10.0.0.4 encapsulation mpls
!
interface Loopback0
ip address 10.0.0.3 255.255.255.255
!
interface POS3/1
ip address 10.0.3.1 255.255.255.252
mpls ip
!
interface FastEthernet4/2
no ip address
switchport
switchport access vlan 8
switchport mode access
!
interface Vlan8
no ip address
xconnect vfi l2vpn


Example 15-8. PE4 Configuration

hostname PE4
!
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp router-id Loopback0
!
l2 vfi l2vpn manual
vpn id 1
neighbor 10.0.0.1 encapsulation mpls
neighbor 10.0.0.2 encapsulation mpls
neighbor 10.0.0.3 encapsulation mpls
!
interface Loopback0
ip address 10.0.0.4 255.255.255.255
!
interface POS3/1
ip address 10.0.4.1 255.255.255.252
mpls ip
!
interface FastEthernet4/2
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk
!
interface Vlan10
no ip address
xconnect vfi l2vpn


Example 15-9. Verifying the VFI Status
PE1#show vfi l2vpn
VFI name: l2vpn, state: up
Local attachment circuits:
Vlan2
Neighbors connected via pseudowires:
10.0.0.2 10.0.0.3 10.0.0.4

PE1#show mac-address-table vlan 2
Legend: * - primary entry
vlan mac address type learn ports
------+---------------+-------+-----+-----------------------
* 2 000b.5fb5.0080 dynamic Yes Fa4/2
* 2 000b.5fad.e580 dynamic Yes
* 2 000b.5fb1.5780 dynamic Yes
* 2 000b.5fb1.5480 dynamic Yes

PE1#show mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
VFI l2vpn VFI 10.0.0.2 1 UP
VFI l2vpn VFI 10.0.0.3 1 UP
VFI l2vpn VFI 10.0.0.4 1 UP

SSO/NSF with GR and / or NSR

Some definitions


HA- High AvailabilityHigh level terminology

SSO -StatefulSwitchover

StatefulSwitchoverAn operating mode where a dual processor router has transferred state information to a standby processor to allow the standby to pickup necessary router functions in the event of an active failure. Mostly refers to L2 information (PPP state, FIB ect) but some L3 applicability. In this operating mode both processors must run identical software versions.


NSF-Non Stop ForwardingNSF


NSF refers to a routers ability to almost immediately start forwarding packets following an active processor failure. The FIB (Forwarding Information Base) is initially transferred and actively updated so that when a failure occurs, the router is able to forward packets while the control plane is rebuilt or refreshed


GR-Graceful Restart


IETF specified mechanisms for interaction between routing protocol peers which allow the peer of a failing device to continue forwarding packets to that device, even though the neighbor relationship has been destroyed.


NSR –Non Stop Routing


A routing protocol operating mode where all information needed to fully maintain the neighbor relationship and all its relevant routing information is transferred (or "checkpointed") to the standby processor. No additional communication or interaction with the routing protocol peer is needed in this mode.Some implementations allow the use of both GR and NSR for the same protocol, but single routing protocol session must be either GR or NSR.






BGP NSF Awareness Timers

This section documents the configuration of the BGP graceful restart timers.

(Optional) The restart-time argument determines how long peer routers will wait to delete stale routes before a BGP open message is received. The default value is 120 seconds.

(Optional) The stalepath-time argument determines how long a router will wait before deleting stale routes after an end of record (EOR) message is received from the restarting router. The default value is 360 seconds



Thursday, July 29, 2010

Optical Fiber Type & Length


Optical fiber

Optical fiber are classified according to several parameters. The most important ones are:


1] Diameter: 9 μm, 10 μm, 50 μm and 62.5 μm
2] Wavelength: 850nm, 1300nm, 1310nm and 1550nm
3] Number of wavelength: Multi-mode Fiber (MMF) OR Single-mode Fiber (SMF)
4] Supported distant range: in meters / kilometers

Generally speaking, the "S" stands for "Short Wave Length" and "L" stands for "Long Wave
Length".

  • LX fibre - e.g. 1GBASE-LX / 1000BASE-LX is available in 50 μm and 62.5 μm as multi-mode fibre (mmf) supporting about 550 meters distance at 1300 nm wavelength. Distances of 2..10 km are possible in case of single-mode fibre (smf).

  • SX fibre - e.g. 1GBASE-SX / 1000BASE-SX is available in 50 μm and 62.5 μm as multi-mode fibre supporting about 250 meters distance at 850 nm wavelength. This wavlength allows for the use of LED transmitters, which are cheaper available then the normally used laser components.

  • FX fibre refers to the 100BASE-FX fast ethernet standard. This fibre type is the long wavelength optics fibre type for 100Mbps transmission systems.

Multiplexing


Some Basic - Digital Signal

First some basic stuff. You will see references to 64K (bits) 'channels' all over the place. This is the basic digital voice signal - called Digital Signal 0 or the infamous DS0 for short. The digital voice signal is encoded using PCM (Pulse Code Modulation) and TDM (Time Division Multiplexing). All other classic copper signal hierarchies, known as PDH - the Plesiochronous Digital Hierarchy, such as T3, are defined as multiples of DS0. Why 64K. Well... to digitize narrowband speech (voice) you take a 4KHz spectrum (actually 3.1K). Normal sampling techniques only give reasonable resolution if sampled at twice the frequency (which gives 2 x 4K(ish) = 8K samples per second). Each sample is 8 bits which gives 8K x 8 = 64K bits per second.

BIT DROPPING - Digital Signal

Now if you think that for a T1 if you multiply 24 x DS0 (64,000) you do NOT get 1.544 Mbit/s instead you get 24 * 64,000 = 1.536 Mbit/s. The extra bits are lost between 'frames' where a frame consists of one 8 bit sample for each of the 24 channels (remember the DS0 basics). So every 192 bits (24 x 8 = 192) we add a 'frame separator' bit to give 193 bits per frame. The final arithmetic is 193 bits x 8K samples = 1.544 Mbit/s. Easy really.
If you do the same arithmetic for DS1C, T2 etc. the above will not give the right answer. In short, above T1 things get really nasty with M-Frames and M-subframes. Its mind numbing stuff and if you really need this information get hold of ANSI T1.107-2002 and lots of coffee or other mind-altering substances.

Optical Carriers

Optical transmission systems are known as SONET (Synchronous Optical NETwork) in North America and SDH (Synchronous Digital Hierarchy) in the Rest of the World. Optical Carriers are typically known by their OC-x number where x is a multiple of the OC-1 rate of 51.84 Mbps (shades of DS0 but a tad faster). While there is a common world-wide standard for optical systems there are differences but they are accommodated within the standard. North America uses an STS-x (Synchronous Transport Signal) format for frames (packets) and Europe an STM-x (Synchronous Transport Module) format because .... well its obvious really, one is from Europe and the other from North America and even if they were both exactly the same, which they are not, the terms would in any case be different. One day if we ever understand the differences we will add some more information.




Wednesday, July 28, 2010

LDP: Label Distribution Protocol Overview

LDP: Label Distribution Protocol Overview

Label Distribution Protocol (LDP) is a key protocol in the MPLS (Multi Protocol Label Switching) architecture. In the MPLS network, 2 label switching routers (LSR) must agree on the meaning of the labels used to forward traffic between and through them. LDP defines a set of procedures and messages by which one LSR (Label Switched Router) informs another of the label bindings it has made. The LSR uses this protocol to establish label switched paths through a network by mapping network layer routing information directly to data-link layer switched paths.
Two LSRs (Label Switched Routers) which use LDP to exchange label mapping information are known as LDP peers and they have an LDP session between them. In a single session, each peer is able to learn about the others label mappings, in other words, the protocol is bi-directional.

OSPF LSA

OSPF -- LSA -- Type


Friday, July 23, 2010

Jitter Buffer - PDV in TDM

Introduction -- TDM-over-Packet -- Jitter Buffer - PDV

The DS34T10x and DS34S10x families of TDM-over-Packet (TDMoP) devices use jitter buffers to compensate for the packet-delay variation (PDV) that is present in packet networks. These buffers are independently configurable on a per-bundle or per-connection basis. Additionally, they are dynamically adjustable, allowing them to be adapted in real-time to changes in the performance characteristics of the packet network. This application note discusses the jitter buffer controller and how to set its parameters to minimize the effects of PDV during TDM clock recovery.DS34T10x comprises the DS34T101, DS34T102, DS34T104, and DS34T108; DS34S10x comprises the DS34S101, DS34S102, DS34S104, and DS34S108.

Timing in a TDM Network

Variations in packet arrival time, called jitter, occur because of network congestion, timing drift, or route changes. Thus, when replacing the physical TDM connection with an IP/MPLS network and two TDMoP devices ,the receiving TDMoP device (slave) receives TDMoP packets with variable delays in arrival time.After processing the packets, the device should send TDM data to the TDM side at the constant rate of the TDM network to minimize the effects of this jitter. To achieve this constant data rate, the device works in clock-recovery mode to reconstruct the source TDM clock so that the destination TDM device can still work in loopback timing mode

There are two kinds of jitter buffers: static and dynamic. The static jitter buffer is hardware-based and is configured by the manufacturer. The dynamic jitter buffer is software-based and can be configured by a network administrator to adapt to changes in the network's delay and PDV.

Types of Pseudowires



Introduction to TDM Pseudowires

Pseudowires(PWs) as a technology originate from the contributions made to
the IETF PWE3 working group, which defined the transport of legacy layer 2
services over an MPLS network. These papers were coined the Martini Drafts
(some were wryly dubbed Dry Martini) after one of the lead authors, Luca
Martini. As such, pseudowires have been in existence for nearly a decade,
mainly in the core and edge of the network, typically transporting ATM and
Frame Relay traffic over a carrier IP network.
RAD has pioneered TDM pseudowires in the access sector, introducing a TDM
pseudowire technology in 1999 at ITU World Telecom in Geneva. Known as
TDMoIP®, this implementation extended the original pseudowire definition into
the access network and to the customer premises. This technology has
enabled carriers and corporate customers alike to provide TDM connectivity
and services over a packet network. TDMoIP pseudowire supports all types of
TDM services: framed, unframed, with or without Channel Associated Signaling
(CAS), enabling a smooth migration to packet networks.

Available Pseudowire Types

Following the successful deployment of TDMoIP gateways by RAD, other
flavors of TDM pseudowires have been developed under the aegis of the IETF.
These pseudowires are known as Circuit Emulation over PSN (CESoPSN) and
Structure Agnostic TDM over Packet (SAToP).

CESoPSN TDM pseudowire technology supports framed and channelized TDM
services over packet switched networks. The main difference between TDMoIP
and CESoPSN is the way CESoPSN packetizes the TDM data. Where TDMoIP
packetizes TDM data in multiples of 48 bytes, CESoPSN uses multiples of the
TDM frame itself.

SAToP (RFC 4553), or Structure Agnostic TDM over Packet, is a TDM
pseudowire technology that differs from TDMoIP and CESoPSN in that it treats
the TDM traffic as a data stream and ignores the framing or the timeslots
(DS0). It provides functionality similar to TDMoIP in its unframed mode.
1] SAToP -- Unframed
2] TDMoIP -- Unfraed , Framed , Channelized
3] CESoPSN -- Framed , Channelized.












Monday, July 12, 2010

VPLS Configuration

VPLS Configuration : The Future





VPLS allows multiple Ethernet LANs from different customer sites to be connected together across the service
provider (SP) network, thereby emulating a single Ethernet LAN segment for that customer.

SP network providing VPLS services in which multiple customer sites (belonging to Customer A) can communicate
as if they are connected as a private Ethernet LAN segment. VPLS uses Multiprotocol Label Switching (MPLS) to
offer multipoint Ethernet connectivity over a mesh of logical circuits or tunnels, with the added benefits of Traffic
Engineering (TE), resilience, and failover. VPLS enables carriers and SPs to offer managed Ethernet VPN services
easily and cost effectively

MPLS Service Provider Configuration

MPLS Service Provider Configuration












Here is the basic configuration of MPLS Service Provider with Route Reflector


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cust_C_1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback10
ip address 10.1.1.1 255.255.255.0
!
interface Loopback20
ip address 10.1.2.1 255.255.255.0
!
interface Loopback30
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 51.1.1.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 10.250.30.2 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0
network 10.1.2.0 0.0.0.255 area 0
network 10.1.3.0 0.0.0.255 area 0
network 10.250.30.0 0.0.0.3 area 0
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end



!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cust_B_1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback10
ip address 10.1.1.1 255.255.255.0
!
interface Loopback20
ip address 10.1.2.1 255.255.255.0
!
interface Loopback30
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 51.1.1.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.250.20.2 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 10
network 10.0.0.0
no auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cust_A_1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback10
ip address 10.1.1.1 255.255.255.0
!
interface Loopback20
ip address 10.1.2.1 255.255.255.0
!
interface Loopback30
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 51.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.250.10.2 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 10.0.0.0
no auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end



!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE_1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
ip vrf CUST_A
rd 65000:100
route-target export 65000:100
route-target import 65000:100
!
ip vrf CUST_B
rd 65000:200
route-target export 65000:200
route-target import 65000:200
!
ip vrf CUST_C
rd 65000:300
route-target export 65000:300
route-target import 65000:300
!
no mpls ip propagate-ttl
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
description **** MPLS Lookback ****
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 51.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.10
description description ***** Connected To Cust_A_1 *****
encapsulation dot1Q 10
ip vrf forwarding CUST_A
ip address 10.250.10.1 255.255.255.252
!
interface FastEthernet0/0.20
description description ***** Connected To Cust_B_1 *****
encapsulation dot1Q 20
ip vrf forwarding CUST_B
ip address 10.250.20.1 255.255.255.252
!
interface FastEthernet0/0.30
description description ***** Connected To Cust_C_1 *****
encapsulation dot1Q 30
ip vrf forwarding CUST_C
ip address 10.250.30.1 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
description ***** Connected To P_CORE_ROUTER *****
ip address 172.16.1.1 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
no auto-summary
!
address-family ipv4 vrf CUST_B
redistribute bgp 65000 metric 1000 10 255 1 1
network 10.0.0.0
no auto-summary
autonomous-system 10
exit-address-family
!
router ospf 10 vrf CUST_C
log-adjacency-changes
redistribute bgp 65000 subnets
network 10.250.30.0 0.0.0.3 area 0
!
router ospf 100
router-id 1.1.1.1
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet1/0
network 1.1.1.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.3 area 0
!
router rip
no auto-summary
!
address-family ipv4 vrf CUST_A
redistribute bgp 65000 metric 5
network 10.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 65000
bgp log-neighbor-changes
neighbor 5.5.5.5 remote-as 65000
neighbor 5.5.5.5 update-source Loopback1
!
address-family ipv4
neighbor 5.5.5.5 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 5.5.5.5 activate
neighbor 5.5.5.5 send-community extended
exit-address-family
!
address-family ipv4 vrf CUST_C
redistribute ospf 10 vrf CUST_C
no synchronization
exit-address-family
!
address-family ipv4 vrf CUST_B
redistribute eigrp 10
no synchronization
exit-address-family
!
address-family ipv4 vrf CUST_A
redistribute rip
no synchronization
exit-address-family
!
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback1
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end



!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE_2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
ip vrf CUST_A
rd 65000:100
route-target export 65000:100
route-target import 65000:100
!
ip vrf CUST_B
rd 65000:200
route-target export 65000:200
route-target import 65000:200
!
ip vrf CUST_C
rd 65000:300
route-target export 65000:300
route-target import 65000:300
!
ip vrf forwarding
!
no mpls ip propagate-ttl
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
description **** MPLS Loopback ****
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
description description ***** Connected To P_CORE_ROUTER *****
ip address 172.16.2.2 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 60.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0.10
description description ***** Connected To Cust_A_2 *****
encapsulation dot1Q 10
ip vrf forwarding CUST_A
ip address 10.240.10.1 255.255.255.252
!
interface FastEthernet1/0.20
description description ***** Connected To Cust_B_2 *****
encapsulation dot1Q 20
ip vrf forwarding CUST_B
ip address 10.240.20.1 255.255.255.252
!
interface FastEthernet1/0.30
description description ***** Connected To Cust_C_2 *****
encapsulation dot1Q 30
ip vrf forwarding CUST_C
ip address 10.240.30.1 255.255.255.252
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
no auto-summary
!
address-family ipv4 vrf CUST_B
redistribute bgp 65000 metric 1000 10 255 1 1
network 10.0.0.0
auto-summary
autonomous-system 10
exit-address-family
!
router ospf 10 vrf CUST_C
log-adjacency-changes
redistribute bgp 65000 subnets
network 10.240.30.0 0.0.0.3 area 0
!
router ospf 100
router-id 2.2.2.2
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/0
network 2.2.2.2 0.0.0.0 area 0
network 172.16.2.0 0.0.0.3 area 0
!
router rip
no auto-summary
!
address-family ipv4 vrf CUST_A
redistribute bgp 65000 metric 5
network 10.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 65000
bgp log-neighbor-changes
neighbor 5.5.5.5 remote-as 65000
neighbor 5.5.5.5 update-source Loopback1
!
address-family ipv4
neighbor 5.5.5.5 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 5.5.5.5 activate
neighbor 5.5.5.5 send-community extended
exit-address-family
!
address-family ipv4 vrf CUST_C
redistribute ospf 10 vrf CUST_C
no synchronization
exit-address-family
!
address-family ipv4 vrf CUST_B
redistribute eigrp 10
no synchronization
exit-address-family
!
address-family ipv4 vrf CUST_A
redistribute rip
no synchronization
exit-address-family
!
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback1
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end



!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cust_A_2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback10
ip address 20.1.1.1 255.255.255.0
!
interface Loopback20
ip address 20.1.2.1 255.255.255.0
!
interface Loopback30
ip address 20.1.3.1 255.255.255.0
!
interface FastEthernet0/0
description description ***** Connected To PE_2 *****
ip address 60.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.10
description description ***** Connected To PE_2 *****
encapsulation dot1Q 10
ip address 10.240.10.2 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 10.0.0.0
network 20.0.0.0
no auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end




!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cust_B_2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback10
ip address 20.1.1.1 255.255.255.0
!
interface Loopback20
ip address 20.1.2.1 255.255.255.0
!
interface Loopback30
ip address 20.1.3.1 255.255.255.0
!
interface FastEthernet0/0
description description ***** Connected To PE_2 *****
ip address 60.1.1.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.20
description description ***** Connected To PE_2 *****
encapsulation dot1Q 20
ip address 10.240.20.2 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 10
network 10.0.0.0
network 20.0.0.0
no auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end



!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cust_C_2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback10
ip address 20.1.1.1 255.255.255.0
!
interface Loopback20
ip address 20.1.2.1 255.255.255.0
!
interface Loopback30
ip address 20.1.3.1 255.255.255.0
!
interface FastEthernet0/0
description description ***** Connected To PE_2 *****
ip address 60.1.1.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.30
description description ***** Connected To PE_2 *****
encapsulation dot1Q 30
ip address 10.240.30.2 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
network 10.240.30.0 0.0.0.3 area 0
network 20.1.1.0 0.0.0.255 area 0
network 20.1.2.0 0.0.0.255 area 0
network 20.1.3.0 0.0.0.255 area 0
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end



!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P_CORE_ROUTER
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
description **** MPLS Loopback ****
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
description description ***** Connected To PE_2 *****
ip address 172.16.2.1 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
description description ***** Connected To PE_1 *****
ip address 172.16.1.2 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 100
router-id 5.5.5.5
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 0
network 172.16.1.0 0.0.0.3 area 0
network 172.16.2.0 0.0.0.3 area 0
!
router bgp 65000
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 65000
neighbor 1.1.1.1 update-source Loopback1
neighbor 2.2.2.2 remote-as 65000
neighbor 2.2.2.2 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
neighbor 1.1.1.1 route-reflector-client
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
neighbor 2.2.2.2 route-reflector-client
exit-address-family
!
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback1
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end